Software

Java

MapR services require the Java runtime environment (JRE) and Java Development Kit (JDK).

Run java -version. Verify that one of these versions is installed on the node:

  • Sun Java JDK 1.7 or 1.8
  • OpenJDK 1.7 or 1.8

If the java command is not found, download and install Oracle/Sun Java or use a package manager to install OpenJDK. Obtain the Oracle/Sun Java Runtime Environment (JRE), Standard Edition (Java SE), available at Oracle's Java SE website. Find Java SE 7 in the archive of previous versions.

Note: The openjdk-devel package includes the jps command that lists running Java processes and can show whether the CLDB has started. This command is not supported in the Sun Java SDK.

Use a package manager, such as yum (RedHat, Oracle Linux, or CentOS), apt-get (Ubuntu) or zypper (SuSE) to install or update OpenJDK on the node. The command will be something like one of these:

RedHat, Oracle Linux, or CentOS

# yum install java-1.7.0-openjdk-devel

Ubuntu

# apt-get install openjdk-7-jdk

SUSE

# zypper install openjdk-7-jdk

MySQL

The MapR Metrics service requires access to a MySQL server running version 5.1 or later. MySQL does not have to be installed on a node in the cluster, but it must be on the same network as the cluster. If you do not plan to use MapR Metrics, MySQL is not required.