1. Upgrade HBase Applications

Prior to performing an upgrade, check to see if your applications contain APIs that were deprecated in the release that you are upgrading to. If you find that an application contains deprecated APIs, update the application to use APIs supported by the version you are upgrading to. You will also need to recompile the application.

For example, in HBase 0.98.x, the CoprocessorProtocol class is deprecated and RegionServer calls to this CoprocessorProtocol class may cause the RegionServer to fail. Prior to upgrade, disable jobs that use the CoprocessorProtocol class and modify the application to use the CoprocessorService instead of the CoprocessorProtocol class.