Configure Hue with Security

Based on the Hue version and the version of the other components that Hue communicates with, you can configure the following security features:

Feature Works with version(s)
MapR-SASL
  • For MRv1: Hue 3.7 or greater and MapR 4.0.2 or greater

  • For Oozie: Hue 3.7-1505 or greater, MapR 4.0.1 or greater, and Oozie 4.0.1 or greater

  • For Hive on YARN: Hue 3.7-1505 or greater, MapR 4.1 or greater, and Hive 0.13-1504 or greater

  • For HttpFS: Hue 3.7-1505 or greater, MapR 4.0.1 or greater, and HttpFS-1504 or greater

  • For YARN: Hue 3.7-1505 or greater and MapR 4.0.1 or greater
  • For Sqoop2: Hue 3.8.1 or greater and Sqoop2 1.99.6 or greater
Kerberos Authentication with MRv1
  • Hue 3.6 or greater
Kerberos Authentication with YARN
  • Hue 3.6 or greater
  • MapR 4.0.1 or greater
Kerberos Authentication with Sqoop2
  • Hue 3.8.1 or greater
  • MapR 5.0 or greater
  • Sqoop2 1.99.6 or greater
SSL Encryption with Hive
  • Hue 3.6 or greater
  • MapR 4.0.2 or greater

SSL Encryption with HttpFS
  • Hue 3.7-1505 or greater
  • HttpFS-1504 or greater
  • MapR 4.0.2 or greater
LDAP Authentication with Hive
  • Hue 3.8.1 or greater
  • MapR 4.1 or greater
Note: You cannot enable both Kerberos and MapR-SASL on the same cluster.