Configure Hue to use MapR-SASL for Hive

As of Hue 3.7-1505, Hue can use MapR-SASL to communicate with Hive 0.13-1504 or greater on a secure MapR cluster that is version 4.1 or greater.

When Hive is configured to use MapR-SASL and the cluster is secure, Hue automatically uses MapR-SASL with Hive.