Configure Hue to use MapR-SASL for Oozie

As of Hue 3.7-1505, Hue can use MapR-SASL to communicate with Oozie 4.0.1 on a secure MapR cluster that is version 4.0.1 or greater.

The default hui.ini file that is installed with Hue (version 3.7-1505 and above) includes the following configurations that allow Hue to automatically detect and set the security configuration:

[liboozie]
      ...
      # Requires FQDN in oozie_url if enabled
      security_enabled=${security_enabled}
      ...
      # Security mechanism of authentication none/GSSAPI/MAPR-SECURITY
      mechanism=${mechanism}
Note: If security_enabled=True and mechanism=MAPR-SECURITY, MapR-SASL will still be used; however, no automatic configuration will occur.