Configuring Impala to Use Sentry Authorization

You can configure Impala to work with Sentry for authorization. When you configure Sentry authorization for Impala, Impala uses operating system IDs to associate privileges with each user that runs the impala-shell or client program.

Before you can configure Impala for Sentry authorization, you must have Hive and Sentry installed and configured to work together.
The following table provides the MapR and component versions required when you want to configure Impala to use Sentry authorization:
Component MapR 5.x MapR 5.1
Impala 2.2.0 2.5.0
Sentry 1.6.0 1.6.0
Hive 1.2.1 1.2.1