Upgrading Spark on YARN

This section describes how to upgrade Spark on YARN without the MapR Installer.

The following instructions explain how to upgrade an existing installation of Spark. Spark will be installed in a new subdirectory under /opt/mapr/spark.
Install the Spark packages.
Note: You only need to upgrade the mapr-spark-historyserver if your previous installation included this package.
On Ubuntu
apt-get install mapr-spark mapr-spark-historyserver
On RedHat / CentOS
yum update mapr-spark mapr-spark-historyserver
On SUSE
zypper upgrade mapr-spark mapr-spark-historyserver