Spark on YARN

This section contains topics about installing, configuring and using Spark on YARN.

Important: Spark 2.0.1 (and later) YARN mode is supported only on clusters in MRv2 (YARN) mode. It is not supported on clusters in MRv1 (classic) mode.

To integrate Spark with other ecosystem components, see Integrating Spark

For additional documentation, see the Apache Spark documentation.