MapR Data Science Refinery Support by MapR Core Version

This topic provides general guidance for which versions of MapR Core you can use with which versions of MapR Data Science Refinery. It also lists features that are exceptions to the general rule.

Each MapR Data Science Refinery release has a corresponding MapR Expansion Pack (MEP) release:

MapR Data Science Refinery Version Number Corresponding MEP Version
1.3 6.0.0
1.2 5.0.0
1.1 4.1.0
1.0 4.0.0

In addition, each MapR Core version supports a set of MEP releases. MEP Support by MapR Core Version shows the support matrix.

In general, you can use MapR Data Science Refinery with the MapR Core version supported by the corresponding MEP release, as well as newer MapR Core versions. For example, because MapR Data Science Refinery 1.3 corresponds with MEP 6.0, which supports MapR Core 6.1, unless otherwise noted, you can use MapR Data Science Refinery 1.3 to access a MapR 6.1 (or later) cluster.

However, there are some exceptions to this general guidance. Some Zeppelin interpreters do not support certain features when using specific MapR Core versions. The following table highlights those exceptions. It includes the version combinations, which are supported for those exception features, to show which MapR Core version you need to use.

Zeppelin Interpreter Feature MapR Data Science Refinery Version MapR Core Version
6.0.0 6.0.1 6.1
Hive interpreter accessing a secure MapR cluster 1.0 Y Y N
1.1 Y Y N
1.2 N Y N
1.3 N N Y
Livy and Spark interpreters accessing MapR Event Store 1.0 1 Y Y N
1.1 Y Y N
1.2 N Y N
1.3 N N Y
1 Not applicable for the Spark interpreter since it was introduced in MapR Data Science Refinery 1.1