Flume 1.6.0-1602 Release Notes

Flume Version 1.6.0
Release Date February 29, 2016
Source on GitHub https://github.com/mapr/flume/tree/1.6.0-mapr-1602
MapR Version Interoperability See Ecosystem Support Matrix
Maven Artifacts http://repository.mapr.com/maven/
Package Names The following packages are associated with this release if you are running 5.0 or 5.1 and install Flume from the repository, or if you are running 5.2 and install MEP 1.0 or 1.1.0:
  • mapr-flume-1.6.0.201602111316-1.noarch.rpm
  • mapr-flume_1.6.0.201602111316_all.deb
If you are running 5.2 and install MEP 1.1.1 or 2.0, see Package Names for MapR Expansion Packs (MEPs).

New in this Release

This release of Apache Flume includes the following behavior change that is specific to MapR:
Support for MapR Event Store For Apache Kafka through the Kafka 0.9 API.
To read MapR Event Store For Apache Kafka topics, you can use a Kafka source or a Kafka channel. To write to a MapR Event Store For Apache Kafka topic, you can use a Kafka channel or a Kafka sink.

For details on the features provided in open source version of Flume 1.6, see the Apache Flume release notes.

Patches

GitHub Commit Date (YYYY-MM-DD) Comment
3e11b9a 2015-12-25 MAPR-21957: Flume now includes support for MapR Event Store For Apache Kafka through the Kafka 0.9 API.
61f6ac3 2016-01-14 MAPR-22162: flume-kafka-channel now has a junit dependency.
0536731 2016-01-14 MAPR-22168: Flume channel now catches UnknownTopicOrPartitionException for the committed() method.
e71cfff 2016-01-19 MAPR-22205: Flume no longer throws NoSuchMethodError when an agent includes an Hbase 1.1 sink and source.