Updating Flume for Compatibility with HBase 0.98

Flume 1.5 is compatible with HBase 0.94 and 0.98. If you are using MapR Version 4.0.x and have upgraded to HBase 0.98, you need to update the Flume 1.5 jar files as follows:

  1. Go to the directory where the Flume scripts are stored:
    cd /opt/mapr/flume/flume-<version>/bin/
  2. Execute the update script:
    bash flume-jars.sh
    During the script execution, you should see the following log messages:
    POST_YARN=1, HBASE_VERSION=0.98.4 : installing flume*-hbase.98-h2 jars
    You can now use Flume 1.5 with HBase 0.98.