HBase Support Matrix

This matrix shows the interoperability between HBase and other ecosystem products.

This page shows the compatibility of HBase with other ecosystem components and it applies to MapR versions 5.1 and below. For more recent versions of MapR, see the MEP Components and OS Support.

Compatible Product Product Version HBase 0.92.2 HBase 0.94.17 HBase 0.94.21 HBase 0.94.24 HBase 0.98.4 HBase 0.98.7 HBase 0.98.9 HBase 0.98.12 HBase 1.1
Hive See the Hive matrix.
MapReduce 1.0.3 Yes Yes Yes Yes Yes Yes Yes Yes Yes
2.4.1 No Yes Yes Yes Yes Yes No No No
2.5.1 No Yes Yes Yes Yes Yes Yes Yes No
2.7 No No No No No No Yes Yes Yes
AsyncHBase 1.4.1 Yes Yes Yes Yes No No No No No
1.5.0 No Yes Yes Yes Yes Yes Yes Yes No
1.6.0 No No No No No No Yes Yes No
1.7.0 No No No No No No No Yes Yes
Hue See the Hue matrix.
Drill 1.0 No No No No Yes Yes Yes No No
1.1 No No No No No Yes Yes Yes No
1.2 No No No No No Yes Yes Yes No
1.3 No No No No No Yes Yes Yes Yes
1.4 No No No No No Yes Yes Yes Yes
1.5 No No No No No Yes Yes Yes Yes
1.6 No No No No No Yes Yes Yes Yes
1.7 No No No No No Yes Yes Yes Yes
1.8 No No No No No Yes Yes Yes Yes
1.9 No No No No No Yes Yes Yes Yes
1.10 No No No No No No No Yes Yes
Impala No 1.2.3 only 1.2.3 only 1.2.3 only 1.4.1 only 1.4.1 only 1.4.1 only 1.4.1 only 2.2.0, 2.5.0
Spark-SQL Spark-SQL goes through Hive to access HBase. See the Spark or Hive matrix pages.
Flume Flume uses the HBase client to use HBase. Flume supports all supported HBase clients.
Storm Storm uses the HBase client to use HBase. Storm supports HBase clients.
Pig 13 No Yes Yes Yes No No No No No
14 No No No No Yes Yes Yes Yes No
15 No No No No No No Yes Yes Yes

Change Control Notes

  • This matrix was updated April, 2017 (Drill 1.10-1703)
  • This matrix was updated on April 4, 2016 (AsyncHBase 1.7).
  • This matrix was updated on Feb 28, 2016 (Drill 1.5).
  • This matrix was updated on Jan 20, 2016 (Drill 0.x removed).
  • This matrix was updated on Jan 12, 2016 (Drill 1.3, 1.4).