Oozie Support Matrix

This matrix shows the interoperability between Oozie and other ecosystem products.

This page shows the versions of Oozie that work with other ecosystem components and it applies to MapR versions 5.1 and below. For more recent versions of MapR, see the MEP Components and OS Support.

Compatible Product Oozie 4.1.0 Oozie 4.2.0
Hive   0.131, 1.01, 1.2.1
Hue 3.8.1, 3.9.0 3.8.1, 3.9.0
Pig   0.14, 0.15
Spark 1.5.2, 1.6.1 1.3.1, 1.4.1, 1.5.2, 1.6.1
Sqoop   1.4.6

1 By default, Oozie 4.2 includes Hive 1.2.1 shared libraries. To use Oozie with other compatible versions of Hive, see the MapR Oozie documentation.

Change Control Notes

  • This matrix was last updated on February 5, 2016 (Oozie 4.1.0 column added).