What's New in MEP 6.1.0

Provides a summary of the new functionality in MapR Ecosystem Pack (MEP) 6.1.0.

MEP 6.1.0 provides support for new features in MapR Database JSON.

MEP 6.x can be used with MapR Core 6.1.0. For more information about MEP and MapR Core version support, see MEP Support by MapR Core Version.

New Features in MapR Database JSON

C# and Go OJAI Clients

With MEP 6.1.0, you can use the C# and Go OJAI clients to write MapR Database JSON applications. Python and Node.js clients also are supported. These clients provide lightweight libraries that support the OJAI API and alternatives to the Java OJAI client. You can connect to MapR Database JSON from middleware components, and add, update, and query documents in a MapR Database JSON table. All clients tailor their features to developers of those respective languages.

The following topics provide more information about these clients:

New Features in Apache Kafka

Support for Kafka Schema Registry

Kafka Schema Registry provides a RESTful interface for storing and retrieving Avro schemas.

For more information, see Kafka Schema Registry.

New Features in Flume

Support for SSL By Default On Secure Clusters for Flume Avro Source and Sink

For more information, see Flume Thrift Security Parameters.

New Features in Oozie

New Oozie Version

MEP 6.1.0 includes support for Oozie 5.1.0.0. See Oozie and Oozie 5.1.0.0-1901 (MEP 6.1.0) Release Notes for more information.

New Features in Tez

Support for Shuffle SSL Encryption Configuration of Tez

For more information, see Tez 0.9.1-1901 (MEP 6.1.0 and MEP 6.0.1) Release Notes.

4-Digit Versions

Transition to 4-Digit Versions Begins with MEP 6.1.0
With MEP 6.1.0, version numbers for some ecosystem components and MapR tools use four – rather than three – digits. In future releases, more components and tools will transition to four digits as new versions of the components are introduced. Four-digit versions enable greater precision and flexibility in the delivery of packages, patches, and Maven artifacts for MapR software. The transition to four-digit versions will happen gradually. In MEP 6.1.0, the following components use four-digit versions:
  • MapR Installer 1.11.0.0
  • Drill 1.15.0.0
  • Oozie 5.1.0.0
  • Spark 2.3.2.0
  • Collectd 5.8.1.0
  • Elasticsearch 6.5.3.0
  • Fluentd 1.3.2.0
  • Grafana 5.4.2.0
  • Kibana 6.5.3.0
For more information about component versions, see: