What's New in MEP 6.3.0

Summarizes the new features in MapR Ecosystem Pack (MEP) 6.3.0.

MEP 6.3.0 provides defect repair and new features as described later on this page.

MEP 6.x can be used with MapR Core 6.1.0. For more information about MEP and MapR Core version support, see MEP Support by MapR Core Version.

MapR Core Support for Red Hat / CentOS 7.7 and Ubuntu 18.04

The MEP 6.3.0 release adds MapR Core support for new versions of Red Hat / CentOS and Ubuntu. For a complete list of supported operating systems, see Operating System Support Matrix (MapR 6.x).

Upgrades Recommended for MEP 4.x and MEP 6.x Installations

The MEP 6.3.0 release includes MEP 6.3.0 and MEP 5.0.4, but no other MEP revisions. Specifically, the MEP 6.3.0 release does not include updates for the following MEPs:
  • MEP 4.0.x on MapR 6.0.1
  • MEP 4.1.x on MapR 6.0.1
  • MEP 6.0.x on MapR 6.1.0
  • MEP 6.1.x on MapR 6.1.0
  • MEP 6.2.x on MapR 6.1.0
If your cluster is currently running one of these MEPs and you want to upgrade to obtain new features or defect repair, you must upgrade to MEP 5.0.4 on MapR 6.01 or MEP 6.3.0 on MapR 6.1.0. For more information about upgrading, see:

Java OJAI Thin Client

MEP 6.3.0 adds a Java OJAI "Thin" Client to the list of lightweight client applications that use the MapR Data Access Gateway to send requests to the MapR data platform. These client applications, which include C#, Go, Python, and Node.js, provide lightweight libraries that support the OJAI API and function as an alternative to the Java OJAI client.

MEP 6.3.0 Ecosystem Components

HBase Support

MEP 6.3.0 includes support for Apache HBase 1.1.13. Previously, the last HBase version supported with MapR Core was HBase 1.1.8. For information about new features, patches, and known issues, see HBase 1.1.13.0-1912 (MEP 6.3.0) Release Notes.

For upgrade considerations, see Considerations for Upgrading to HBase 1.1.13.

To configure MapR-SASL security, see Configure MapR-SASL Security (Authentication and Encryption) for HBase.

For MapR HBase documentation, see HBase.

Drill 1.16.0.10

MEP 6.3.0 includes support for Drill 1.16.0.10.

For a list of updates, see Drill 1.16.0.10-1912 (MEP 6.3.0) Release Notes.

Hive 2.3.6

MEP 6.3.0 includes support for Hive 2.3.6.

For a list of new features and updates, see Hive 2.3.6-1912 (MEP 6.3.0) Release Notes.

Hue 4.3.0 with Livy 0.5.0

MEP 6.3.0 includes support for Hue 4.3.0 with Livy 0.5.0.

For a list of new features and updates, see Hue 4.3.0.100-1912 (MEP 6.3.0) Release Notes.

Impala 2.12.0.100
MEP 6.3.0 includes support for Impala 2.12.0.100.

For a list of updates, see Impala 2.12.0.100-1912 Release Notes.

Oozie 5.1.0.300
MEP 6.3.0 includes support for Oozie 5.1.0.300.

For a list of updates, see Oozie 5.1.0.300-1912 (MEP 6.3.0) Release Notes.

Spark 2.4.4.0

MEP 6.3.0 includes support for Spark 2.4.4.0.

For a list of new features and updates, see Spark 2.4.4.0-1912 Release Notes.

MapR Installer Support for MEP 6.3.0

Mapr Installer 1.13.0.0 supports MEP 6.3.0 and maintenance MEP 5.0.4, as well as previously released MEPs. For more information, see Release History for MEPs and MapR Installer Updates.