Prerequisites for Using the MapR Data Fabric for Kubernetes

To use the MapR Data Fabric for Kubernetes, you must have the following software versions:
Component Supported Versions
MapR-XD 5.2.2 or later
MapR Expansion Pack (MEP) Any MEP supported by MapR 5.2.2 or later. See MEP Support by MapR Core Version.
Kubernetes Software 1.9*
OS (Kubernetes nodes) All nodes in the Kubernetes cluster must use the same Linux OS. Configuration files are available to support:
  • CentOS
  • Red Hat (use CentOS configuration file)
  • SUSE (use CentOS configuration file)
  • Ubuntu
Note: Docker for Mac with Kubernetes is not supported as a development platform for containers that use the MapR Data Fabric for Kubernetes.
Volume Plug-in 1.0 or later. The download location shows the available versions of the plug-in. Plug-ins are supported for:
  • CentOS
  • Ubuntu
  • Microsoft Azure AKS
  • Red Hat OpenShift**
  • Google Kubernetes Engine (GKE)
Note: Amazon EKS is not currently supported.
Provisioner 1.0 or later. The download location shows the available versions of the provisioner.
POSIX License*** The Basic POSIX client package is included by default when you install the MapR Data Fabric for Kubernetes. The Platinum POSIX client can be enabled by specifying a parameter in the Pod spec.

To enable the Platinum POSIX client package, see Enabling the Platinum Posix Client. For a comparison of the Basic and Platinum POSIX client packages, see Preparing for Installation.

*Kubernetes alpha features are not supported.

**OpenShift Origin is supported because it supports Kubernetes 1.9. The OpenShift Container Platform (formerly known as OpenShift Enterprise) can be used only if it supports Kubernetes 1.9.

***Only the POSIX client is supported. NFSv3 is not supported.