Packages and Dependencies for MapR Software

Package and dependency details for MapR 6.1 platform and ecosystem components.

For downloadable packages, see these links:
For MapR Installer package dependencies, see:
This table shows the MapR 6.1 package dependencies for Red Hat / CentOS and SUSE. A dash (—) indicates no dependency.
This package . . . Depends on . . .
These MapR packages These non-MapR packages
mapr-apiserver mapr-core
mapr-cldb mapr-core

mapr-fileserver

mapr-client

mapr-librdkafka

glibc

libgcc

libstdc++

syslinux

mapr-compat-suse

/etc/default/useradd

/sbin/rpcinfo

/usr/sbin/acpidump

libffi4

libgcc_s1

libsnappy1

libstdc++6

openssl

mapr-core

mapr-core-internal

mapr-hadoop-core

mapr-librdkafka (version 0.11.3 or later)

mapr-mapreduce2

mapr-core-internal

dmidecode

glibc

hdparm

initscripts

irqbalance

libgcc

libstdc++

nss (version 3.19 or later)

redhat-lsb-core

sdparm

shadow-utils

syslinux

mapr-fileserver mapr-core
mapr-hadoop-core

mapr-core-internal

mapr-historyserver mapr-mapreduce2
mapr-loopbacknfs

iputils

nfs-utils

redhat-lsb-core

rpcbind

mapr-mapreduce2 mapr-hadoop-core
mapr-nfs mapr-core

/usr/sbin/rpcinfo

iputils

nfs-utils

mapr-nodemanager mapr-mapreduce2
mapr-posix-client mapr-client
mapr-resourcemanager mapr-mapreduce2
mapr-single-node

mapr-cldb

mapr-fileserver

mapr-nfs

mapr-webserver

mapr-zookeeper

mapr-upgrade mapr-core rpmrebuild
mapr-webserver mapr-apiserver
mapr-zk-internal
mapr-zookeeper

mapr-core

mapr-zk-internal

These MapR 5.x packages were removed for MapR 6.x:
  • mapr-jobtracker
  • mapr-mapreduce1
  • mapr-metrics
  • mapr-tasktracker

This table shows the MapR 6.1 package dependencies for Ubuntu:

This package . . . Depends on . . .
These MapR packages These non-MapR packages
mapr-client

mapr-librdkafka (version 0.11.3 or later)

awk

bash (version 2.05a-11 or later)

coreutils (version 5.0-5 or later)

grep (version 2.4.2-3 or later)

libc6

libgcc1

libstdc++6

perl

procps (version 1:2.0.7-8 or later)

sed (version 3.02-8 or later)

syslinux

mapr-core-internal

adduser (version 3.11 or later)

awk

bash (version 2.05a-11 or later)

coreutils (version 5.0-5 or later)

dmidecode

grep (version 2.4.2-3 or later)

hdparm

libc6

libgcc1

libstdc++6

lsb-base

irqbalance

perl

procps (version 1:2.0.7-8 or later)

sdparm

sed (version 3.02-8 or later)

syslinux

sysvinit-utils

mapr-loopbacknfs

iputils-arping

lsb-base

rpcbind

mapr-nfs mapr-core

awk

bash (version 2.05a-11 or later)

coreutils (version 5.0-5 or later)

grep (version 2.4.2-3 or later)

iputils-arping

nfs-common

perl

procps (version 1:2.0.7-8 or later)

sed (version 3.02-8 or later)