PAM Authentication for Spark

Spark supports PAM authentication on secure MapR clusters.

In MEP-5.0.0, PAM authentication and encryption is enabled by default for all Spark Web UIs. After running configure.sh, if the cluster is secure and Spark is installed, Spark will be configured using PAM.

Note: Spark PAM is available in Spark-2.2.1 from MEP-5.0 and in Spark-2.1.0 from MEP-4.1.1.

See Configuring PAM for information on how PAM works with MapR.