Zeppelin 0.8.2-1912 Release Notes

The notes below relate specifically to the MapR Distribution of Apache Zeppelin. You may also be interested in the Apache Zeppelin project homepage and the following Apache Zeppelin 0.8.x changelogs:
Version 0.8.2
Release Date December 2019
Source on GitHub Zeppelin: https://github.com/mapr/zeppelin

Livy: https://github.com/mapr/livy

GitHub Release Tag Zeppelin: 0.8.2-mapr-1912

Livy: 0.5.0-mapr-1912

Docker Image Name and Tags
Image Name Operating System Version of the Running Container Tag
maprtech/data-science-refinery CentOS 7.7 v1.4.1_6.1.0_6.3.0_centos7
Ubuntu 16.04 v1.4.1_6.1.0_6.3.0_ubuntu16

Zeppelin on MapR is a component of the MapR Data Science Refinery. This release of Zeppelin is in version 1.4.1 of the MapR Data Science Refinery.

The Data Science Refinery is packaged as a Docker container. MapR ecosystem components included in the Docker image are the same as those in the MEP 6.3.0 release. For product version details, see MEP 6.3.0 Components and OS Support.

You can run the Docker image on the following operating systems:

  • Linux (CentOS 7.x, Ubuntu 14, Ubuntu 16)
  • Windows 10 Pro (64-bit)
  • Mac OS X 10.11

The following are the verified browsers:

  • Chrome 57
  • Firefox 56.0
  • Microsoft Edge 40
  • Safari 9.0

The MapR product documentation is available at Zeppelin on MapR.

New in this Release

Zeppelin in MapR Data Science Refinery 1.4.1 has updated dependencies to be compatible with MEP 6.3.0. Specifically:

  • Zeppelin is updated to 0.8.2 patch release.
  • Zeppelin is now compatible with Spark 2.4.4.
  • Updated list of available Helium plugins to most recent version.
  • Updated joda-time library to 2.10.3.

Fixes

This release by MapR includes the following fixes on the base Apache release. For complete details, refer to the commit log for this project in GitHub.

Commit Date (YYYY-MM-DD) Comment
c5f52f2 2019-10-22 Change zeppelin.server.addr back to 0.0.0.0 after ZEPPELIN-4166
fbba6a5 2019-11-18 [ZEPPELIN-4214]. Spark Web UI is displayed in the wrong paragraph
be3bea6 2019-11-19 CORE-332 Joda Time Library for Brazil
444c1c6 2019-11-19 DSR-94 Update list of Helium plugins to recent version
80a5809 2019-11-21 MZEP-182 Install git package in DSR images

Known Issues and Limitations

  • MZEP-17: The HBase interpreter cannot be used to query MapR Database Binary tables
  • MZEP-79: Legends in plots do not display correctly when running the Matplotlib (Python/PySpark) example from the Zeppelin Tutorial
  • MD-2397: Zeppelin cannot connect to Drill through the JDBC driver on a secure MapR cluster when Zeppelin has Kerberos authentication enabled
  • MZEP-86: You cannot run Zeppelin as user 'root'
  • MZEP-110: You cannot use a custom R environment with Zeppelin
  • DSR-27: You cannot access MapR Event Store For Apache Kafka using either the Livy or Spark interpreters with Data Science Refinery 1.2, if you are connecting to a MapR cluster older than version 6.0.1.
  • DSR-62: You cannot access MapR Event Store using either the Livy or Spark interpreters with MapR Data Science Refinery 1.1 and 1.2, if you are connecting to a MapR 6.1.0 cluster.
  • ZEPPELIN-1904 - Pandas dataframe.plot does not work in the Python and PySpark interpreters

For issues that apply to running MapR Docker images, see MapR PACC Known Issues.