MapR 5.0 Documentation : Upgrade before applying License

If installing a new cluster, make sure to install the latest version of MapR software. If applying a new license to an existing MapR cluster, make sure to upgrade to the latest version of MapR first. If you are not sure, check the contents of the file MapRBuildVersion in the /opt/mapr directory. If the version is 1.0.0 and includes GA then you must upgrade before applying a license. Example:

# cat /opt/mapr/MapRBuildVersion 
1.0.0.10178GA-0v

For information about upgrading the cluster, see Cluster Upgrade.