If you use Maven to manage your application dependencies, follow these instructions to set up the POM file for your HBase client application or HBase server application.

For existing applications

If you have an existing application that currently works with an earlier version of MapR-DB and you want to run it on MapR-DB 5.0 instead, make these changes in the POM file for your HBase client application or HBase server application:

  1. Follow either of these steps to update the value in the <groupID> tags:
    1. For client applications, replace “hbase” with “hbase-client” in the <groupID> tags.
    2. For server applications, replace “hbase” with “hbase-server” in the <groupID> tags.
  2. In the version tags, make these changes:
    1. Replace the HBase version with 0.98.12.
    2. Replace the number following mapr with 1506.
    3. Replace the version number following m7 with 5.0.0.

If you have an existing application that works with Apache HBase and you want it to run on MapR-DB 5.0 instead, make these changes in the POM file for your HBase client application or HBase server application:

  1. Follow either of these steps to update the value in the <groupID> tags:
  2. For client applications, replace “hbase” with “hbase-client” in the <groupID> tags.
  3. For server applications, replace “hbase” with “hbase-server” in the <groupID> tags.
  4. Use this value for the version: 0.98.12-mapr-1506-m7-5.0.0

If you want to use a different version of MapR-DB, you can find the JAR file versions listed in the following locations. Copy and paste the version you need into the <version> tags in the POM file for your HBase client application or HBase server applicationIf the version you use makes use of Apache HBase 0.98.7 or earlier, ensure that “hbase” is between the <groupID> tags.

For new applications

If you are creating a new application to work with MapR-DB, you can download a POM file from either of these locations for the version of MapR-DB that you want to use: